Some customers might experience major issues with Inbox
Incident Report for Zowie
Resolved
Incident has been fully resolved
Posted May 22, 2023 - 09:33 UTC
Monitoring
We've been able to mitigate the issues and are now monitoring the application
Posted May 22, 2023 - 09:27 UTC
Investigating
We are currently investigating this issue.
Posted May 22, 2023 - 09:10 UTC